MBF Motorcycle Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter · #1 ·
I have had my Raider for 3 weeks now, after the first week i noticed my speedo wasn't working.
So i took it back to the dealer and he said if it happens again to call him. I took it to another dealer and he ordered me another speedo cluster thats day. It's on backorder for a while. I was wondering if anyone else had the same problem.
 

·
Registered
Joined
·
141 Posts
I've put 400 miles on so far and my speedo acts fine. Let u know if I start to experience any problems. I'm sure it is a isolated case. Were you messing with any wiring on the bike lately?
 

·
Registered
Joined
·
154 Posts
No problems to report here.
I've nearly 900 miles on my Raider and rode in the night and in the rain last night.
I finally got to enjoy that lit up speedo.
Has anyone else enjoyed the lighting at night on their speedo's?

I set my speedo for full bright not dim.

Best,
Ken
 

·
Registered
Joined
·
220 Posts
Same here Nomad - just had her out at night for the first time :D Man I love that blue speedo!

TOPIC:
No issues here with 370 miles on her. I'll keep an eye on her tomorrow on our 150 mile run to see if anything out of the ordinary happens.
 

·
Registered
Joined
·
29 Posts
Discussion Starter · #10 ·
Dealer finally called and said to bring my bike in for speedo cluster replacement. While i was there i had them put the flamed ISO grips on. He called me back when he was finished said it was done . I asked him if he put the miles back on the odometer. He said no, now i have a brand new Raider. It had almost 1500 miles on it when i brought it in.
 

·
Registered
Joined
·
740 Posts
i've got 300 on my raider and i had the same problem. i just pulled the seat and pushed the connectors in a little more and they clicked. the connector wasnt clicked all the way in, so i pushed it in and kept on riding (happened as i was riding..looked down one second i was going 40..next second 0.)

might've just been a loose connection
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top