MBF Motorcycle Forums banner
1 - 13 of 13 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
I have the Cobra dragsters. I installed my Fi200r last night. Andre @ Cobra told me to unplug my O2 sensor and plug up all the connections. I haven't made any adjustments to the processor yet. I'm still getting the backfire. The instructions say for the popping on trailing throttle to adjust the green (far left pot). Has anyone done this yet and if so did it take the backfiring and popping out?
 

·
Registered
Joined
·
373 Posts
I have the Fi200r CL, I also have the Cobra Swepts. After I installed the fi200R, I had a little bit of popping on decel and shifting. I moved the green pot setting to 2 and it has stopped popping.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #4 ·
WaRaider-
When I expose the pots, is ther an arrow of some sort to show what # I have it set to. I just kind of glanced @ it before I installed it and don't recall any indication as to what actual setting each pot was on.
 

·
Registered
Joined
·
373 Posts
cox1244 said:
WaRaider-
When I expose the pots, is ther an arrow of some sort to show what # I have it set to. I just kind of glanced @ it before I installed it and don't recall any indication as to what actual setting each pot was on.
I just figured it was factory set at one, so I just turned to two.
 

·
Registered
Joined
·
220 Posts
I had the same issues - my popping also went away at 2.

BUT - I dropped my bike off at a local speed shop to get dialed in just right. I'll post my findings/horse/torque when she gets back.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #7 ·
Hey guys-
I have dialed my Fi200r (left pot) all the way to "4". I thought that would be way too rich and called Cobra. They said that was probably too rich and that pot shouldn't be higher than around 2.5 to 3. I've now got it Set @ about 2.5 and it's still popping and backfiring. Cobra said I would have some here & there due to the V twin but I think I'm getting too much
Does anyone have the dragsters w/ the Fi200r that can tell me what settings you're using. I'm not sure what to do w/ the other 2 pots. I'm not getting any hesitation and it seems to be running fine mid range and top end---just still back firing
 

·
Registered
Joined
·
219 Posts
cox1244,

Check the thread in this forum on crossed coil wires.

I installed the Fi2000r and still had plenty of popping/backfires, found the crossed coil wires and 90% of the popping in gone.

fisher
 

·
Registered
Joined
·
46 Posts
Here's obviously a newbie question: is the popping "bad"?

I drilled the ends of my stock pipes (four each, about 7/8" holes) and immediately got popping on decel - not backfiring, just intermittant pops, only when I downshift and let the clutch out. I actually thought they sounded cool, but if I've done something that's hurting the engine, please someone tell me! And better yet, if there's a way to fix it.

Thanks.
 

·
Registered
Joined
·
155 Posts
In addition to the crossed coil wires. Do you use your engine kill switch when you stop the bike? If so, do you switch it back on before you turn your key on? If not, the FI may not be doing its job. Thumb through the directions again, I don't have then in front of me at the moment, I'll check later unless someone answers first. Oh, and are either of your crush gaskets leaking? I've been told this could make the bike back fire.

Brian
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #11 ·
I never use the kill switch. I just use the key. Should I be using the kill switch? If so what is the order to turn off then start back up?
 

·
Registered
Joined
·
826 Posts
The first thing to check if you are getting excessive popping is the coil wires on the right side of your bike. I was getting all kinds of popping with the cobra slashdowns so installed the fuel controller and it still didn't help.I was dissapointed cause i heard the stock unit should compensate for an exhaust change, and when the fuel controller didn't fix the problem I was a bit perplexed. Then the issue of the crossed coil wires came up and i switched them and I am fine with or without the fuel controller plugged in. Hardly no popping at all.
 

·
Premium Member
Joined
·
1,178 Posts
daveu said:
Here's obviously a newbie question: is the popping "bad"?

I drilled the ends of my stock pipes (four each, about 7/8" holes) and immediately got popping on decel - not backfiring, just intermittant pops, only when I downshift and let the clutch out. I actually thought they sounded cool, but if I've done something that's hurting the engine, please someone tell me! And better yet, if there's a way to fix it.

Thanks.
The intermittent popping that you're hearing is no problem. You're just hearing some of the noises that the baffles normally hide when they don't have holes in them.

Re: the kill switch - I've always thought of it as an emergency measure only. I always leave it on "Run" and use the key and thumb starter switch. If you ever drag race, you can screw a lanyard into the kill switch, and if the bike ever gets away from you, it kills the engine.
 
1 - 13 of 13 Posts
Top