MBF Motorcycle Forums banner
1 - 15 of 15 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
Hey guys-
I'm new to the site. This is awsome. I'm in Charlotte, NC. I've got the red S model. I have the Cobra dragsters sitting in the box in my garage waiting to be installed. My Fi200r is supposed to be here "mid week". I haven't seen it. The guy installing these for will be out of town for three weeks. What would happen if I just installed the pipes w/o the processor?
Thanks
Mike
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #3 ·
Why do i need it then?---did i waste my money. I guess the only way to find out if the bike is running rich or lean is to check the plugs?
 

·
Premium Member
Joined
·
1,178 Posts
Checking the plugs is one way you can do it. If you have a shop with a Dyno near you, they can tell as well during a pull. You didn't necessarily waste your money. The stock ECU will probably adjust enough for the Dragsters. If you decide to make more extreme changes later on - intake, etc. - you might need to augment to stock ECU
 

·
Registered
Joined
·
326 Posts
yes i agree with nj its not a waste i just thought you wanted to install the pipes before your programmer came in, so i was letting you know that it will run fine without it, but it will probably make more power with it ;D
 

·
Registered
Joined
·
220 Posts
ao said:
nothing, it will run fine ;D
This is true. You will be "good to go" with just exhaust.

NJRaider said:
Checking the plugs is one way you can do it. If you have a shop with a Dyno near you, they can tell as well during a pull. You didn't necessarily waste your money. The stock ECU will probably adjust enough for the Dragsters. If you decide to make more extreme changes later on - intake, etc. - you might need to augment to stock ECU
Also troo. We have a "closed loop" O2 system - so the stock 'puter will adjust necessary AFR's.

My Cobra Swepts, Fi2000R O2 and K&N filter should be coming tomorrow (according to UPS tracking). I ordered the controller simply because I am going to mod my stock air box and toss in a K&N air filter... more air = more fuel needed.

The stock bike is set to run lean from factory - adding the fuel controller from Cobra will richen the mixture to the low 13's high 12's - it will increase throttle response and get rid of that "lag" you get from stomping on it at low RPM's as well as help the bike run cooler (as if BLACK wasn't cool enough! yo!)
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #7 ·
Thanks guys.
I'll go ahead and install the pipes and keep an eye on it. To the ear, I shouln't be able to tell if it's running rich or lean, right?

On another note: I've gotten a lot of info already from all of you. I'm getting my chrome belt guards, side mount plate bracket, and my tail light assy (performace edge). That will start me off for a while.
 

·
Registered
Joined
·
220 Posts
If you start blowing black smoke at idle while the bike is cold... you're running a bit lean. Happened to my buddy's '07 Warrior until he threw in a Power Commander. Other than that - your bike should be fine. AO has pipes on without a fuel controller and he's A-OK thanks to the factory unit.
 

·
Registered
Joined
·
326 Posts
you wont be able to tell by the sound but you can get a little and i mean little smell of the exhaust and if it burns your nose and makes your eyes water its running rich ;D
 

·
Registered
Joined
·
220 Posts
ao said:
you wont be able to tell by the sound but you can get a little and i mean little smell of the exhaust and if it burns your nose and makes your eyes water its running rich ;D
That reminds me too much of my old whip - tuning it with a MAP clamp, lol. "MORE FUEL!" lol.
 

·
Registered
Joined
·
38 Posts
Hey Cox -

Installed my Cobra swepts yesterday. Rode today for about 100 miles with no problems. Maybe a "pop" here or there, but running fine. Although that could just be me getting used to the new roar.

I do as well have the Fi2000r coming in and plan on installing it along with a BAK kit once one come out for the Raider. I will install the Fi hopefully next week.

BTW - The 02 sensor is connected to the pipe where Ninja described. But it's run up behind the side frame under the seat where a female and male end meet. You have to remove the fuse box to get at them. I don't know if it's the same with the dragsters, but I had to remove that unit from under the seat and re-route it. Wasn't a problem, just FYI....

Good luck...
 
1 - 15 of 15 Posts
Top