MBF Motorcycle Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
I got my swepts installed this afternoon. They look and sound fantanstic. I very happy with them. Good fit, no issues there. Only trouble I had was with the removal of that darn 02 sensor. That little bugger did not want to come off without a fight. Took a while to figure out how to "nicely" get it off.
FYI - It will not be installed to the original spot because the 02 sensor connector is not long enough once attached to the new location on the swepts. That info would have been helpful before hand. Also Cobra does not supply the new crush gaskets, so I picked them up from my dealer. $9 per.

I took a quick video to show you. Like most it uploaded video's, you can't truly appreciate the sound or visual. It's a HD video but uploaded is not very good quality. They really make that 1900 rumble and roar. You know it means business but not too loud or obnoxious. I'll be taking it out tomorrow to really get a feel for it. Should be close to 70 and sunny.
[googlevid=425,350]http://video.google.com/videoplay?docid=-1951058523708982599[/googlevid]
 

·
Registered
Joined
·
530 Posts
Damn they sound and look great. I hope I dont have to wait till May 10th to get mine in but I had to go through the Stealer here and they order through Parts unlimited I think.. I am sure the stealer wont be as anxious as I am to call Parts unlimted every few days and get an update. ???

FYI - It will not be installed to the original spot because the 02 sensor connector is not long enough once attached to the new location on the swepts. That info would have been helpful before hand.

So what did you end up doing to fix this?? Do you mean the wires are not long enough to reach from the spot on the swepts??

Congrats
 

·
Registered
Joined
·
168 Posts
I went to autozone, bought me some wire and made it longer.
Just be carefull not to mix the wires.
I did it one wire at a time and added about six inches to each one.
Did not have a problem hooking it up.

GC
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
Thanks Big Easy - I'm using the FI2000R C/LOOP. I ordered it at the same time as the pipes, but it has not come in yet. It's running fine without. Makes me wonder of the value add. But the FI is supposed add some performance gains and fuel efficiency. So say Cobra's Dyno charts.

NH - I didn't do any splicing. You have to re-route the 02 connector behind the frame rail right, below the fender but above the swing arm, and over the hill, through the woods.... I tucked it behind the frame just below the fender chrome bracket behind some heat shielding Then zip tied it to an existing plastic bracket that holds other tubing. Out of the way and works fine. I read the instructions before hand, but they are not intuitive. No worries, it just would have made my work faster knowing I didn't have to put it back in it's original position. That 02 sensor just gave me fits getting it out....
 

·
Premium Member
Joined
·
1,178 Posts
Hey Roch -

The stock ECU on the Raider is significantly more adaptable than a lot of the other bikes out there. You might not need the FI, considering that the stock unit can compensate for the change in airflow.

Try this - run your bike through about 7 start-run-stop cycles to give your ECU a chance to adjust. After that, run it wide open and kill the engine without running at idle, pull and read your plugs - it'll give you a good idea if the bike is running lean, rich or right where it should be.

Remember that the purpose of the FI2000 or any other controller is only to add or take away fuel to make sure that the correct air/fuel ratio is maintained. It won't add power by itself.
 

·
Registered
Joined
·
41 Posts
They look great "Wa", and shows me what My bike is gone to look like by noon time Friday(if my ups man comes on time). My goal is to run without baffles, somebody has to make a statement to the big dogs, iron horses, and whatever else out there. :ricky:
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #14 ·
I'm still waiting on the Cobra Fi2000r to be delivered. I haven't read any manuals yet, but haven't heard anthing about unplugging the 02 sensor. The Cobra FI allows the Raider to continue to use the close loop system with the existing 02 sensor for correct emissions, but then when you're really banging on it , it adjusts for optimum air/fuel ratios for peak performance. I wonder if the 02 in this case is for emissions only, or if it's needed to run correctly with the on-board ECU.

You've got me curious. I'm going to call Cobra tomorrow and see what they say.

Where did you get the BAK? I didn't think Patrick or anyone else had one out yet for the Raider. Thunder Mfg still says sometime in June. Are you using one for the Stratoliner/Roadliner?
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top