Light/Electrical Problems
Results 1 to 15 of 15

Thread: Light/Electrical Problems

  1. #1
    Veteran Member v8Buck's Avatar
    Join Date
    Oct 2007
    Location
    Newton Grove, N.C.
    Posts
    1,480

    Default Light/Electrical Problems

    Starting today my running, brake, headlight and left turn signal lights do not work. The horn works, water pump is ok, fan is ok, 2 sets of independently wired auxiliary lights are ok. The right turn signal does not activate properly when the button is pushed but it does flash. All fuses have been checked and are ok. Why crap seems to happen right before Daytona is beyond me.
    Suggestions are appreciated, remember that I am electrically stupid.
    Buck
    02 small block
    WIFE- '06 Roadliner


  2. Remove Advertisements
    MyBikeForums.com
    Advertisements
     

  3. #2
    Veteran Member HogV8's Avatar
    Join Date
    Dec 2003
    Location
    Parish, NY E of Lake Ontario
    Posts
    7,256

    Default

    Buck , sounds like you may have a bad ground . Check the ground wire on the frame . My ground is on the frame near the fuse box and another ground up under the neck where the horn mounts . I think yours should be the same . Also check any other plug in ground connections for corrosion or a possible broken ground wire .
    Jack DeLelys......2000 Boss Hoss 350/400 HP

  4. #3
    Veteran Member v8Buck's Avatar
    Join Date
    Oct 2007
    Location
    Newton Grove, N.C.
    Posts
    1,480

    Default

    Jack, PM sent
    Buck
    02 small block
    WIFE- '06 Roadliner


  5. #4
    Veteran Member
    Join Date
    Dec 2003
    Location
    Raleigh, NC
    Posts
    504

    Default

    Quote Originally Posted by v8Buck View Post
    Starting today my running, brake, headlight and left turn signal lights do not work. The horn works, water pump is ok, fan is ok, 2 sets of independently wired auxiliary lights are ok. The right turn signal does not activate properly when the button is pushed but it does flash. All fuses have been checked and are ok. Why crap seems to happen right before Daytona is beyond me.
    Suggestions are appreciated, remember that I am electrically stupid.
    Buck
    The answer is "Your bike knows that Bike Week is soon". It's like clockwork. If all else fails put it in the trailer and we'll fix in in the Tropic Shores parking lot. Besides, you can ride bitch behind Susan until then .
    V8 Bike Prof

    It's o.k. if you disagree with me, I fully respect your right to be wrong.


  6. #5
    Veteran Member v8Buck's Avatar
    Join Date
    Oct 2007
    Location
    Newton Grove, N.C.
    Posts
    1,480

    Default

    Besides, you can ride bitch behind Susan until then
    that'll be a trick since she has a solo seat.
    I'm going to pop the tank tomorrow and see if I can find that ground Jack speaks of, failing that, it's Mountain time as soon as we get to Daytona.
    Several years ago Susan's bike completely died as I was loading it on the trailer for a trip to Biketoberfest; another time her bike died in Daytona, she bought some gas that ended up looking like tar.
    I have helped do the parking lot mechanic thing a couple of times, it was Susan's older bike and then a friends, thank God.
    We still don't know for sure when we're heading down as I have asked TSR to see if they had a couple of extra days, haven't heard anything yet, will call tomorrow if still no response.
    Buck
    02 small block
    WIFE- '06 Roadliner


  7. #6
    Veteran Member
    Join Date
    May 2005
    Location
    Northeast Ohio
    Posts
    860

    Default

    Before I go any further.. I'm no electrical expert. Just trying to help and throw out ideas..I was thinking if you have a badlands (or similar) unit for your tail/running lights. that is something that might fail to cause all of those circuits to fail at the same time.. Good luck Buck..
    I I want it all!

  8. #7
    Veteran Member v8Buck's Avatar
    Join Date
    Oct 2007
    Location
    Newton Grove, N.C.
    Posts
    1,480

    Default

    Randy, I have 2 separate units, the rear is a run/brake and the front is the turn signal unit, both installed by MBH. By virtue of the fact that I do not have a working h/light but all other electrical functions that are controlled by separate relays work would lead me to believe that Jack might have the answer, a bad ground. I'll post if and when it's located and fixed. Thanks for the heads up.
    Buck
    Last edited by v8Buck; 02-29-2012 at 07:16 AM.
    02 small block
    WIFE- '06 Roadliner


  9. #8
    Veteran Member
    Join Date
    May 2005
    Location
    Northeast Ohio
    Posts
    860

    Default

    Good luck Buck, hope it's something easy to fix..
    I I want it all!

  10. #9
    Veteran Member v8Buck's Avatar
    Join Date
    Oct 2007
    Location
    Newton Grove, N.C.
    Posts
    1,480

    Default Electrical Problem (FIXED)

    Thanks Jack and Randy for the advice, the problem was a loose, corroded terminal on the rear of the fuse panel. Easy fix, Daytona look out, we're coming.
    Buck
    02 small block
    WIFE- '06 Roadliner


  11. #10
    Veteran Member HogV8's Avatar
    Join Date
    Dec 2003
    Location
    Parish, NY E of Lake Ontario
    Posts
    7,256

    Default

    Glad you found your problem . Apparently you have one of the new style Boss Hoss fuse boxes with pigtail spade connectors ??
    Jack DeLelys......2000 Boss Hoss 350/400 HP

  12. #11
    Veteran Member v8Buck's Avatar
    Join Date
    Oct 2007
    Location
    Newton Grove, N.C.
    Posts
    1,480

    Default

    yes, the new style, see y'all in a week and 1/2
    Buck
    02 small block
    WIFE- '06 Roadliner


  13. #12
    Veteran Member HogV8's Avatar
    Join Date
    Dec 2003
    Location
    Parish, NY E of Lake Ontario
    Posts
    7,256

    Default

    I'll be there this Sat , YEEEEEEHAAAAA
    Jack DeLelys......2000 Boss Hoss 350/400 HP

  14. #13
    Veteran Member v8Buck's Avatar
    Join Date
    Oct 2007
    Location
    Newton Grove, N.C.
    Posts
    1,480

    Default

    and we just booked 2 extra days so we'll be there on Friday the 9th; since you ride about 8 miles from our house we could meet for lunch or supper at the Benson,NC exit #79, first exit south of the I-95/I-40 interchange or the Dunn,NC exit #73, about another 5-6 miles south.
    Buck
    02 small block
    WIFE- '06 Roadliner


  15. #14
    Veteran Member HogV8's Avatar
    Join Date
    Dec 2003
    Location
    Parish, NY E of Lake Ontario
    Posts
    7,256

    Default

    Thanks anyway Buck but we are going to try to drive right thru if we can so I don't really want to make any plans . We'll see you in Daytona maybe at the Metz Friday afternoon the 9th .
    Jack DeLelys......2000 Boss Hoss 350/400 HP

  16. #15
    Veteran Member v8Buck's Avatar
    Join Date
    Oct 2007
    Location
    Newton Grove, N.C.
    Posts
    1,480

    Default

    you can bet your bippy that we'll be there probably around 4-430ish or so
    safe trip..
    Buck
    02 small block
    WIFE- '06 Roadliner


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •